Service Performance Issues on Public Browser

Incident Report for SNOMED International Tooling

Resolved

This incident has been resolved.
Posted Oct 13, 2025 - 17:52 UTC

Investigating

We are receiving reports of performance issues with this service. The team are currently investigating and will post an update shortly.
Posted Oct 13, 2025 - 14:43 UTC
This incident affected: Public SNOMED Browser.